Ultimate RC Home RC Forum RC Videos RC Photos RC Projects & others
Affiliate links:
Sign in:
Reply
Thread Tools
valium's Avatar
"Experienced user"
valium - 4.20.17, 6:26 pm Post #1: | Reply With Quote
My buddy gave me his stock 2wd slash to try to fix because I've become an rc nerd. He bought it used from a guy and the servo went out in a day. No big deal, could've been abused. Well, he bought a brand new one and it also lasted a day. I hooked the servo up to a receiver I know for a fact works and nothing happened. Took it out, and took it all apart. No failed solders, no obvious sign of manufacturer failure. I believe it could be a bad ground within the esc or receiver. What do you guys think?
Traxxas Revo (soon to be erevo)
Traxxas XO-1
Traxxas Bandit VXL
Traxxas Slash 4x4 1/16
lsear2905's Avatar
"Hasa Diga Eebowai!"
lsear2905 - 4.20.17, 6:39 pm Post #2: | Reply With Quote
Check your receiver settings? Maybe the steering plug is reversed in the receiver?
from Melbourne, Australia (where Winter is Summer, and we use the metric system)

Bored? Check out and follow my Instagram feed @mycousinscrogg
Really bored? lsear2905's Garage in the General RC section
Want even more? Check out my flickr page at flickr.com/lsear
valium's Avatar
"Experienced user"
valium - 4.20.17, 6:44 pm Post #3: | Reply With Quote
I've plugged it into 3 different receivers. Nothing happened on all 3. Stock one, the one on my xo1, and then my spare spektrum system
Traxxas Revo (soon to be erevo)
Traxxas XO-1
Traxxas Bandit VXL
Traxxas Slash 4x4 1/16
lsear2905's Avatar
"Hasa Diga Eebowai!"
lsear2905 - 4.20.17, 7:57 pm Post #4: | Reply With Quote
I misunderstood - are you trying the one that failed after one day with all 3 receivers? Sounds like it's dead. Can you take it back to where it was bought?
from Melbourne, Australia (where Winter is Summer, and we use the metric system)

Bored? Check out and follow my Instagram feed @mycousinscrogg
Really bored? lsear2905's Garage in the General RC section
Want even more? Check out my flickr page at flickr.com/lsear
valium's Avatar
"Experienced user"
valium - 4.21.17, 4:46 am Post #5: | Reply With Quote
They won't take one after it's been used. I'm just trying to find out why it's killed two servos in two days. I understand the 2075 isn't the best servo in the world, but it will survive on a 2wd slash
Traxxas Revo (soon to be erevo)
Traxxas XO-1
Traxxas Bandit VXL
Traxxas Slash 4x4 1/16
"Experienced user"
Billy Kelly - 4.21.17, 5:24 am Post #6: | Reply With Quote
Something is definitely wrong. I've got 5 year old Traxxas servos that work fine. Something has to be shorting them out instantly.
If store won't take them back. Traxxas should send replacement. Not best servo but it works.
valium's Avatar
"Experienced user"
valium - 4.21.17, 5:43 am Post #7: | Reply With Quote
I'll call them today probably. I feel like it's just a bad ground within something.
(Last edited by valium : 4.21.17 at 5:45 am) Reason: Posted twice
Traxxas Revo (soon to be erevo)
Traxxas XO-1
Traxxas Bandit VXL
Traxxas Slash 4x4 1/16
thebasher255's Avatar
"brushed motors are fast too"
thebasher255 - 4.21.17, 8:15 am Post #8: | Reply With Quote
It's most likely a damaged bec in the esc. Had it happen to a cc bec on a friend's crawler one time. The bec would output full battery voltage from a 3s lipo, which killed a $100 savox servo almost instantly. I would check the bec output with a volt meter if you can. It should be at 6 volts for a traxxas esc.
Smell something burning? Sorry, I was thinking.
Reply
Thread Tools


All times are GMT -7. The time now is 8:34 pm.


Original content & design copyright ©2000 - 2016, Bamidele O. Shangobunmi & the Ultimate RC Network. Privacy policy
Manufacturer/vendor images, names, & trademarks are copyrights of their lawful owners & used with permission and/or within Fair Use guidelines.

JANG's LEGO blog - JANGBRiCKS @ YouTube - Playmobil reviews