Ultimate RC Home RC Forum RC Videos RC Photos RC Projects & others
Affiliate links:
Sign in:
Reply
Thread Tools
thegrafxguy's Avatar
"Experienced user"
thegrafxguy - 12.27.16, 9:44 pm Post #11: | Reply With Quote
How do you know they were bad? What speed were the red flashes?
RC8.2e Factory Team - RC Gear Shop 2150kv, HW XERun SCT Pro, Savox 1260 Servo

Sakura D4 AWD - Tacon 3930kv, HW EZRun 60a, Blue Bird Servo

Spektrum DX4S
Traxxas780's Avatar
"Experienced user"
Traxxas780 - 12.27.16, 10:14 pm Post #12: | Reply With Quote
They would go into shutdown mode and couldnt turn off just red fladhing. my batteries worked in other cars so I bought a whole new esc motor combo and it worked
fyrstormer's Avatar
"Precision Basher"
fyrstormer - 12.27.16, 11:23 pm Post #13: | Reply With Quote
Any chance there was a bad solder joint in the ESC's power plug? You'd still get full voltage, at least until you mashed the throttle, and then the massive resistance from the bad solder joint could make the voltage downstream from the power plug sag far enough to trip the ESC's low-voltage cutoff.
Check out "Fyrstormer's Garage" in the General RC forum.
Traxxas780's Avatar
"Experienced user"
Traxxas780 - 12.28.16, 9:03 am Post #14: | Reply With Quote
I havent looked but they were traxxas soldered and like 7 years. Probably telling me time for ann upgrade
thegrafxguy's Avatar
"Experienced user"
thegrafxguy - 12.28.16, 9:17 am Post #15: | Reply With Quote
Fair enough man, but next time maybe take some of our advice and troubleshooting. Will help us help you in the future if we know we aren't just getting blown off
RC8.2e Factory Team - RC Gear Shop 2150kv, HW XERun SCT Pro, Savox 1260 Servo

Sakura D4 AWD - Tacon 3930kv, HW EZRun 60a, Blue Bird Servo

Spektrum DX4S
DrJVogel's Avatar
"Obstacle Magnet"
DrJVogel - 12.31.16, 11:30 am Post #16: | Reply With Quote
There is always the good folks at Traxxas Support. Even us old timers need the help of the tech departments. Castle Creations knows me all too well! Best of luck with the fix.
RC addict and loving it
somewhere near Grass Valley, CA --- let's bash
"Regular user"
motoergosum - 1.02.17, 3:51 pm Post #17: | Reply With Quote
When I had that happen with my Ultimate it was because the Traxxas nimhs were fried. Switched to Gens Ace 3S and it's run worlds better.
Reply
Thread Tools


All times are GMT -7. The time now is 3:25 am.


Original content & design copyright ©2000 - 2016, Bamidele O. Shangobunmi & the Ultimate RC Network. Privacy policy
Manufacturer/vendor images, names, & trademarks are copyrights of their lawful owners & used with permission and/or within Fair Use guidelines.

JANG's LEGO blog - JANGBRiCKS @ YouTube - Playmobil reviews