Ultimate RC Home RC Forum RC Videos RC Photos RC Projects & others
Affiliate links:
Sign in:
Reply
Thread Tools
"Experienced user"
cucac - 7.13.14, 7:09 am Post #1: | Reply With Quote
I have just recently bought a slash 4x4 #6808 at BestBuy.ca and just after 2 weekends having fun the TQi transmitter doesn't turn on for no apparent reasons. It just dies. No green light when i turn it on. I check the batteries and they are full. I check the wire harness and it seems solid with all the solder joins. I even checked circuit board with volt meter and it seems responsive when i give a throttle or a steering a nudge. But the green light is not on. I suspect the 2.4GHz transmitter itself in the controller is dead/fried.

I have a normal new TQi without the iPod docking base. I have noticed that some have problems with iPod docking base while updating the firmware and render its useless. But mine is just nornal new TQi transmitter one but it still dies. I wonder this is common with all Traxxas new TQi controller.

My questions: Anyone else has this same problem? Is there another good budget transmitter out there that you would suggest? I see some suggest Radiolink RC3S 4ch controller but really don't know if it's compatible with the slash 4x4. Is it just a matter swapping out Tx/Rx in the car and reset the ESC with this RC3S? I am new to this

My review for Slash 4x4 #6808 "FUN IF IT CAN RUN"
RallyX3s's Avatar
"Experienced user"
RallyX3s - 7.14.14, 7:12 am Post #2: | Reply With Quote
Call traxxas support, they are prettt good and should be able to hook you up.
LizardXO-1's Avatar
"A random guy on the internet"
LizardXO-1 - 7.14.14, 7:34 am Post #3: | Reply With Quote
Seems to be a common problem. I had the same with my TQI with dockingbase. It just didn't turn on anymore someday. Did not do a firmware upgrade oder removed the iPod or something, just tried to turn it on.
"Experienced user"
Blue - 7.14.14, 7:43 am Post #4: | Reply With Quote
LOL "pretty good"
Calling Traxxas support is an exercise in futility.
I called them 3 times over the same issue and got 3 different answers. Then proceeded to figure out the problem myself.
Good Luck.
RallyX3s's Avatar
"Experienced user"
RallyX3s - 7.14.14, 12:39 pm Post #5: | Reply With Quote
Blue said
LOL "pretty good"
Calling Traxxas support is an exercise in futility.
I called them 3 times over the same issue and got 3 different answers. Then proceeded to figure out the problem myself.
Good Luck.
Can't rule it out just because you had a issue with them. Let the guy give it a shot.
"Experienced user"
Blue - 7.14.14, 3:09 pm Post #6: | Reply With Quote
RallyX3s said
Can't rule it out just because you had a issue with them. Let the guy give it a shot.
I never said anything about "ruling it out". I said it was an exercise in futility. I wanted to make him aware of my experience with them. I even wished him luck.

"Experienced user"
cucac - 7.15.14, 3:04 pm Post #7: | Reply With Quote
Yeah, called and explained nicely what the problem is. Asked me what kind of batteries I am using. Said I use my 4x AA Sanyo Eneloop batteries. Is it a rechargeable? Of course they are rechargeable. And he went on saying the transmitter is not supposed to use with rechargeable batteries (I don't know what he's talking about. my fully charged Eneloop is about 1.44V if it doesn't work what will?????) , He told me to use alkaline batteries to see if it's work. I told him just give me RMA and I send it in and you can put whatever kind of batteries to see if it works.

Good transmitter product shouldn't die in 3 weeks of good use. I have a -[DISALLOWED]--[DISALLOWED]--[DISALLOWED]--[DISALLOWED]--[DISALLOWED]--[DISALLOWED]- 27Mhz Airtronic transmitter but it's still doing strong after 8 years.

Honestly I love my Traxxas Slash 4x4 as a truck. It's a well built truck no doubt. But the transmitter that comes with it is garbage.

As I said "Fun if It can Run"
"Experienced user"
bkr11 - 1.19.15, 10:33 am Post #8: | Reply With Quote
Just happened to me... I'll be calling as well.
Cornholio1's Avatar
"Experienced user"
Cornholio1 - 1.19.15, 1:12 pm Post #9: | Reply With Quote
cucac said
Honestly I love my Traxxas Slash 4x4 as a truck. It's a well built truck no doubt. But the transmitter that comes with it is garbage.
Actually it isn't. I've got 2 brand new ones and 2 older ones and they all work flawlessly. Every manufacturer will have a few products that will fail, that certainly doesn't mean that they're all garbage.
Slash 4x4 -Mamba Max Pro SCT 2400KV-3s and 4s Lipos
Big Bore Shocks-RPM Front And Rear Bumpers

RC10GT -Blue Chassis-O.S CVR (.18)
"Experienced user"
bkr11 - 1.19.15, 4:01 pm Post #10: | Reply With Quote
Hey Cornholio - quick question. Have you used the iOS Link app on either of the newer ones? What I heard from Traxxas support is the iOS app is known to cause this on some of the controllers. On the forums on the Traxxas site there was somebody who took delivery of their 4x4 Ultimate around Christmas (of this year) and he has already grenade two. I agree that there will always be a few products that fail, but it sounds like this is a known (occasional??) glitch that they really need to address.

I revived this thread from the dead since the search found it, but the issue is alive and well.
Reply
Thread Tools


All times are GMT -7. The time now is 12:07 am.


Original content & design copyright ©2000 - 2016, Bamidele O. Shangobunmi & the Ultimate RC Network. Privacy policy
Manufacturer/vendor images, names, & trademarks are copyrights of their lawful owners & used with permission and/or within Fair Use guidelines.

JANG's LEGO blog - JANGBRiCKS @ YouTube - Playmobil reviews