Ultimate RC Home RC Forum RC Videos RC Photos RC Projects & others
Affiliate links:
Not a Member Yet? You're Missing Out!
Sign up in minutes for a free URC Network account and you'll be able to post in over 100+ forum categories, search over a decade of archived topics, exchange private messages with other members, upload pictures to the RC photo galleries, and much more!

Already have an account?
Sign in below!
Sign in:
Reply
Thread Tools
PlaneCarBoat's Avatar
"Experienced user"
PlaneCarBoat - 5.17.13, 1:17 pm Post #1: | Reply With Quote
I just got a Traxxas TQI 2.4 GHz Radio and receiver. I put it in my Kyosho Rally Ep Fazer with a Duratrax Sprint Esc. I think I have it binded but the throttle won't work and the steering is reversed. Any ideas?

If you need pictures, I can get some.

Thanks
two250's Avatar
"Experienced user"
two250 - 5.17.13, 1:27 pm Post #2: | Reply With Quote
Make sure throttle is in Channel 2, there are two Channel 1 inputs on the TQi. To reverse the steering you will need to go into the settings and flip Channel 1, check Traxxas' site for a TQi manual. After that calibrate the ESC to the radio and check throttle, if the ESC fails to calibrate you may need to reverse Channel 2 as well...
Race- LOSI: Ten-SCTE 2.0, 22T, 8ight-T 2.0 E-conversion - KYOSHO: Mini-Z
Bash- TRAXXAS: E-Revo, XO-1, Spartan - LOSI: Mirco SCT, Micro Baja - HPI: Sprint 2 Drift, Savage XS Flux - AXIAL: SCX10
"Experienced user"
jdobratz - 5.17.13, 1:27 pm Post #3: | Reply With Quote
Did you calibrate the traxxas system to your ESC? Check the manual for your ESC on how to do that if you haven't. Here is the link to the TQi manual with instructions on how to reverse the steering channel (page 14).
PlaneCarBoat's Avatar
"Experienced user"
PlaneCarBoat - 5.17.13, 1:38 pm Post #4: | Reply With Quote
Got the steering reversed! How do I calibrate my esc to the radio. Keep in mind the steering is working properly.
"Experienced user"
jdobratz - 5.17.13, 1:48 pm Post #5: | Reply With Quote
I think these are the instructions for your ESC, based on the info in your first post.

Also, verify that your ESC is plugged into channel 2 and that +,-, and signal wires are connected to the correct pins on the receiver, as two250 said.

Manual

Before you begin this step, your speed control should be plugged into
the receiver and your transmitter should have already been adjusted.
Before you connect the main battery pack to the speed control, make
sure that the ESC switch is turned off. Connect the battery pack to the
speed control and turn on the transmitter. Make sure the throttle
trigger is in the Neutral position before turning on the ESC.

1) With the transmitter throttle trigger in neutral, turn on the ESC. The
green LED will light up for about 1 second.

2) Pull the throttle trigger to full forward, the red LED will light up to
indicate the full forward is now being operated.

3) Push the throttle trigger to full reverse, the green and red LED will
light up to indicate full reverse is now being operated.

4) The ESC will hold this setting until it is reset.

5) Repeat this procedure if any or all steps fail to operate as expected.

(Note: The motor does not function during the set-up process.)

Note: If the throttle is set to full forward on the transmitter and you get
reverse operation instead of forward operation,
PlaneCarBoat's Avatar
"Experienced user"
PlaneCarBoat - 5.17.13, 1:57 pm Post #6: | Reply With Quote
My Esc's lights are not on at all.

There is no switch on my esc either.

I'm a bit of a newbie when it comes to RC's. Sorry in advance
"Experienced user"
jdobratz - 5.17.13, 2:01 pm Post #7: | Reply With Quote
I this what you have? The picture shows a switch and the manual does as well.

http://www3.towerhobbies.com/cgi-bin/wti0001p?&I=LXAMN7
PlaneCarBoat's Avatar
"Experienced user"
PlaneCarBoat - 5.17.13, 2:17 pm Post #8: | Reply With Quote
Yes thats it! I didn't think that was the right switch. still no lights are coming on on my esc. There are lights on my receiver though
PlaneCarBoat's Avatar
"Experienced user"
PlaneCarBoat - 5.17.13, 2:48 pm Post #9: | Reply With Quote
What should I do?
"Experienced user"
jdobratz - 5.17.13, 2:50 pm Post #10: | Reply With Quote
I think your ESC is plugged into the wrong slot on the receiver, or you've got it plugged in backwards.

Is this the receiver that you have? Even if it isn't, from a quick look at tower all of the current models are setup pretty much the same.

Make sure you ESC is plugged into the third slot from the bottom. The first two are channel 1 for single or dual steering servos. The third is your channel 2/throttle channel. Also, make sure the black or negative wire is facing toward the right of the receiver, there are small markings on the bottom of the receiver which tell you what each pin is for.
Reply
Thread Tools


All times are GMT -8. The time now is 3:43 pm.


Featuring: Ultimate Tamiya, Traxxas Slash forum, Slash 4x4 forum, Ultimate RC forums

Original content & design copyright ©2000 - 2013, Bamidele O. Shangobunmi & the Ultimate RC Network. Privacy policy
Manufacturer/vendor images, names, & trademarks are copyrights of their lawful owners & used with permission and/or within Fair Use guidelines.

Lego fan? Check out JANG's LEGO blog and LEGO videos on YouTube